Extremely low FPS/Stuttering on high end gaming laptop


#1

I ordered the digital deluxe edition sometime back, and I’ve had nothing but issues since pre-loading the game and installing on release day.

My system is well above the recomended requirements and should be able to play the game on ultra or pretty close to it, but I seem to be having serious issues with framerate.

Specs:
i7 4820MQ @ 2.5ghz (turbo to 3.4)
SLI GTX970m’s with 3GB DDR5 VRAM
16GB 1333mhz RAM

I’ve tried running the game on all different settings, vsync on and off, single GPU and in SLI, and no matter what I do, the max frame rate I seem to be able to squeeze out is never above 40 FPS.

I’ve been monitoring my temps, and I’ve noticed that my CPU is barely being utilized. the temps hardly move off their idle temps and it doesn’t appear to be using anywhere near as much as most of my games use.

Is there any fix for this? it’s extremely infuriating to invest in a system that should be able to run PC games flawlessly only to have one game be borderline unplayable.


#2

Dumb question, but did you upgrade to the latest drivers? 'cause they come ready to run Evolve super good.


#3

New SLI drivers, and the CPU is a little underwhelming. Make sure it’s utilizing turbo or force ghz in BIOS?


#4

Latest drivers, and I haven’t tried forcing turbo yet.

I also realized, I have a roughly -80mV undervolt on my CPU for temperature reasons… perhaps that’s the cause. Otherwise, I’m stumped.

Edit; Upon using some google foo, there is no foolproof way of forcing turbo on an intel CPU. I can alter P-states but there’s no guarantee I won’t wreck my computer by messing around with that stuff. I shouldn’t have to in the first place to run this game.


#5

I get my Alienware 15 (2015) today and I will try evolve and let you know my frame rates.

980M

will be running 1920X1080 @ Very High


#6

I have the same problem with my alienware m14x with gtx765m. On low settings im getting 18-24 fps. Really annoying pre-ordering a game and not being able to play it.


#7

so, the problem has been solved.

My CPU for some reason was clocked at 0.8Ghz… the game now runs as it should, Very High @ 60-120FPS with SLI enabled.


#8

Figured out its our laptop makers and not the game!!!

Got the new Alienware 15 with 980M and was getting 23 fps… I was like WTF!!!

Found out they don’t know how to test a PC at alienware and included only a 180 watt AC, so the CPU was throttling to 800Mhz…

Got a 240 watt AC from them and now the issue is gone. up to 65-75 fps @1080P very high.

They are working on a BIOS update too that may improve performance even more.


#9

I just got a 15 last week. How were you able to determine the amount of power you need? Thanks for the great info!


#10

thats the only one they are willing to give as a replacement, I wanted the 330 Watt


#11

I’m pretty sure it’s not just your laptop, and performance in general is very sketchy right now:

Hopefully Turtle Rock can fix the problem. (And before you ask, yes, I’ve done the sys_MaxFPS = 200 trick; didn’t help.)