Evolve web page

#1

I’m super upset I can’t get on my phone to check evolve updates anymore. I checked almost every day and you guys keep letting me down on everything. I loved evolve but now it’s like I don’t know what happened to it. Now I can’t even see updates that a paid good money for I’M SICK OF THIS. Good day

#2

What site are you having issues with?

#3
#4

What phone/browser are you using?
It works fine for me. Galaxy S4/Chrome

1 Like
#5

No idea what you’re talking about dude… It works fine for me. That sounds more like a “You” problem.

#6

Charge that phone!!! :open_mouth:

2 Likes
#7

Shhhhhh, it’s okay. It’s just it’s time.

2 Likes
#8

What’s funny is that was the first thing I noticed too.

2 Likes
#9

No that worked fine but here’s the thing I had to put my birth date in again, which I could put the date in fine but it wouldn’t allow me to press enter. Cause before they updated you could actually hit the enter button :neutral_face:

#10

Everything but enter worked on mine
I’m on my IPhone 5 going through the Google app.

#11

Does switching to Desktop view work?

What about a different mobile browser?

#12

Safari didn’t work

#13

This is all that happens on safari and my laptop after you press enter nothing loads. You still can’t press enter over the Google app though.

#14

Well I figured out it prefers one over the other. I just can’t go to Official Site of Evolve the Game | Turtle Rock Studios | 2K. Which is the one I always went on. But I guess not anymore

#15

This is so strange. I tested the site last night on my desktop and chromebook, in IE (or whatever the WX version is called) and chrome. I had zero issues.

#16

It is really strange but I guess it’s whatever :pensive:

#17

Try one more thing. Try deleting any cookies or using an incognito/private browsing window.

#18

Lol 2% battery life left :smile: wait… reads 1% battery life on my phone

2 Likes
#19

Well I eventually got it to work 1 out of the 4 ways I could get on the site. Which is odd but I managed to :sweat_smile:

closed #21