Evolve Stage 2 (Founder Status)

Type (ie. Gameplay, UI): Characters Locked
Character: All
Map/Map Location: N/A
Game Mode: All
Platform: PC

Can you tell us the steps to reproduce the issue or what you were doing when the issue occurred?

  1. Play the game…

Any additional information (pictures, videos, errors codes, etc) to help reproduce or locate the problem?
I’ve been away from the game for a few weeks and came back today to find out my Founder Status is no longer working on Stage 2.

I’ve lost access to all my characters, I seen this was a problem in September, already tried every fix on that thread and none worked.

Know what, forget it.

I’m leaving for good, not in the mood for this.

If you do come back, you’ll have to contact my2K customer support for issues with your founder status. Sorry you’re having trouble!

1 Like

This is possibly due to syncro-issues with your connection to the servers, in which I suggest to try deleting the my2k cache:

What you also can try is simply, to check and uncheck the Founders pack box in the DLC list when you go to the Game in your Library.

1 Like

@ToiletWraith, @DarKastle, would this be considered a goodbye thread, considering that the OP later posted that he was quitting?

1 Like

We’re leaving it for now in case the above items help.

2 Likes