Evolve Stage 2 Fails To Launch

stage2
pc

#1

Evolve Stage 2 used to work, but recently it fails to launch.
This is the only game that fails to launch, all the other games work.

When i launch the game it says its preparing to launch evolve then asks me if i want to run it, if i say yes it goes back to preparing to launch and asks me again this goes on forever. if i say no then i get a failed to start game (unknown error)

I have verified game files, reinstalled/repaired all the stuff in the _CommonRedist folder, my firewall is not blocking it

I’ve looked through other topics and nothing has fixed my issue


#2

Did you have the game before Stage 2?

Are you running Steam as an administrator?


#3

I didnt have it before stage 2 and am running it as an administrator


#4

Hm, seems like you’ve tried a lot of the commonly suggested things.

Going to tag @miyagi_nosaj - he should be able to help you out when he can.


#5

This will fail if the exe is set to run as administrator. Go to the exe options and uncheck that. However, it still needs admin to run (no idea why). For this make sure STEAM is ran with administrative rights. Close steam completely out and open it as admin. Otherwise we will need the logs.


#6

If what @fox_news says doesn’t work, then I’ll have to bring in some heavy guns. @ArPharazon just so this is on your radar.


#7

Sounds like some kind of delivery problem with Steam. If the Steam Stuck section in the self help topic doesn’t help, try some of the other stuff here (be warned, it’s a long read):

The “failed to launch game” message also reminds me of old bug topics where it turned out an antivirus program (usually AVG) was falsely triggering on Evolve.exe and blocking or quarantining it.


#8

Setting it to run as not admin fixed it sort of, it loads now but it loads to a black screen, the sound and mouse show up and i can hear the sounds when i scroll over where the buttons should be, if i CTRL ALT Delete and run the task manager and come back to the game it runs just fine.

In case my description is a little lacking here’s a video of the issue
Link


#9

You have the latest update, yes?


#10

Steam says its up to date


#11

By any chance are you using Raptr or the AMD gaming evovled app?

I noticed that both during Legacy and Evolve Stage 2 that the apps tend to cause black screens and other loading issues.
When I have encountered a similar issue in Steam, it turned out that my Son was also using my account to play games on his steam machine. (check to make sure you are on the one and only authorized computer)

Hope something helps here.


#12

I’m not running any overlay apps like overwolf, raptr or AMD and my computer is the only one with this steam account


#13

have you tried deleting the user data?


#14

If i delete the user data then i no longer have this problem, but if i change the resolution to reduce lag it goes into the black screen mode thing. So i dropped down the graphics quality and left the resolution unchanged.

I’m going to say problem solved


#15

@TheMountainThatRoars solved


#16

Disturbing that you can’t change resolution but at least you can play. Perhaps try windowed mode or windowed full screen.


#17

Hi! I want to add on to this post cos I have a similar problem but with sort of a workaround. So as OP said:

I read somewhere that it was because the game resolution was set to a different resolution than the native resolution of the PC (in my case 1920x1080), so I found out that if I had set the game resolution to 1920x1080 before launching the client (either before I quit the game or via GeForce Exp), it launches normally, but if I didn’t or forgot to (e.g. 1360x768 fullscreen), the issue will occur. (I have to set it to a lower resolution just to play the game smoothly.) Alt-Tab or Task Manager and then going back in solves it, I would be able to see everything.
If windowed on a lower resolution, it works. If windowed borderless, that’s worse cos I won’t be able to alt-tab back to normal.


#18

Changing resolution with Evolve’s video options menu leaves you with a black screen?


#19

Not with the video options menu (although the textures will become pixelised but alt-tab solves that too), but rather, if I start the client with a different resolution on fullscreen or borderless window, it will be a black screen.


#20

The menu is the only supported way to control those things… I assume you must be editing settings.xml directly? Breakage should be expected if so. Why don’t you want to use the menu?