Evolve Stage 2 CTD On startup

Hi. Im curious if theres something I’m able to do to fix this issue, but from reading other posts who have the same issue as me it seem they don’t have any luck either. I’ve done everything that everyone has commonly done, the directx Installer and MIcrosoft c++ installer the Patch directs and VcRedistr. I had uninstalled and re-installed many times. I had my friend try to help me out he said it might be a hard drive issue because I played the game before on the other graphics card that I had. I had the Geforce GTX 750. Now i have the 1050TI but everything else is the same. So i was also having some issues with other games as well so I was like I need a new hard drive anyway. So I bought a brand new one and re-installed just my gaming stuff. Starting with steam and evolve to see if that had fixed it. It didn’t sadly. But I tried the other games I had and everything worked fine. I’ve seen posts on other threads of the devs being notified and they would help. Idk if everyone has the same issue or different ones that cause the same issue. But im posting to see if theres anything I can do or get a dev to note I’m also having the issue. Thank you :upside_down_face:

Unfortunately, TRS no longer have the rights to Evolve or Evolve Stage 2. If you want Dev support you need to reach out to 2k.


The thing I would try is installing different graphics drivers to see if that solves your issue. It may be you need to roll back to an older version if you have the latest driver installed


There’s a thread that was made when Stage 2 launched with info on common problems. Anyone have a link by chance? I’m on my phone :frowning: if no one replies by the time I’m in tomorrow, I’ll get you the link HotNacho :slight_smile:

Welcome to the forums!

1 Like

Tagging @ArPharazon and @TheMountainThatRoars since they’ll know what I’m talking about!


Ah yes, self help! Thanks TMTR!


Do you get any error messages?

sigh I guess it’s going to be like many I saw on other forums, they ask something and “poof” they’re forever gone.

1 Like

Yeah that’s kind of the sad part. But there is still a lot of dedicated people here. :sunglasses:

1 Like

I dont get any error message. I looked in the game error log and it had to do something with it not liking full screen. So I adjusted that with Geforce Experience to start in window borderless and it was still giving me the same error and everything.

I’ve been busy with work and school and haven’t had time to mess with anything involving games. But Evolve Stage 2 is the only game I’m having issues with. My buddy logged into my computer to see if It was an account issue but on his account it crashed instantly as well.

I’ve also done that, rolled back the graphics driver, then uninstalled the drivers and used a different one and I was still getting the same issue.

1 Like

Oh sorry but a lot of people just leave after a few minutes after they ask a question.

1 Like

Have you checked if your Vram is tweaked? Maybe it’s due to the Vram, try to follow this method, maybe it’ll work for you (personally, I haven’t noticed any difference when I tested).

If you’re able to launch the game for at least the menu, try to lower the graphics settings to the lowest possible (if it hasn’t been done).

Also try this stuff


Try to open the game in different resolutions and -autoconfigs and stuff like that.Maybe one of them will work.

Make the geforce experience default so it won’t overlap, and use the steam commands instead

That doesn’t work with Stage 2, only with Legacy. It writes things into the settings that break Stage 2. Please look through the self help topic for the relevant section so you can go about undoing it. I think you need to run a batchfile to delete your local user data.

Edit: Sorry, I was at the gym earlier and spoke in haste. I leaped to the conclusion that you had used GeForce Experience to “Optimize my game” (don’t do that), but on reflection I realize you never said that.

If you were trying to influence the game by changing driver settings, I think your chances would be best leaving them all at defaults.

If you did delete user data, there would be no harm done. You haven’t been able to run the game yet, so you have nothing to lose there.

Edit 2: Given that you previously played the game on a different gfx card, actually I would recommend going ahead with deleting all user data for Evolve. Worth a try.

Edit 3: this

1 Like

Can you paste that text and whatever else is nearby it?

1 Like

ArPharazon 2 things one is I had my friend do that when he was messing with it the other day. I was using a different graphics card but deleted everything so it was completely fresh had my friend help me delete everything and retried, When i first launched it after setting it up the first time I left it at default but it gave me the full screen error thing so i tried to adjust using geforce because un doing fullscreen.

  1. I wasnt able to locate the error it was giving me last time however i tried multiple troubleshooting fixes and it still CTD with no warning or error codes. I should have taken a screenshot when I found it the first time.

To WiBaKi I have adjust the resolution of fullscreen and borderless windows. I tried doing it with steam as default it gave me the same error stuff

My Vram isnt tweaked. I double checked it just now. I don’t even get into the menu, it crashes on the evolve claw logo, furthest I’ve gotten was the partnerships or w/e screen right after that and it crashes, i’ve tried to adjust the graphics using geforce and made them all the lowest they could be and it still CTD no warning or errors.