Evolve Hunters Quest : Bucket badge still locked after hunter's level 30


#1

Hello, my Bucket reached level 30 but unfortunately the badge didn’t unlock.

My Parnell reached level 30 the same game Bucket did and his badge is unlocked. I did tap Parnell’s “level up” but i’m pretty sure i didn’t for Bucket, that might be the reason.

Steps to reproduce (maybe, don’t have time to try it out and don’t want to miss another badge :stuck_out_tongue: ) :
1/ Get 2 hunters to 95% of their 29th level
2/ Win a game with them
3/ Tap the “Level Up” of Hunter 1# , don’t tap it for Hunter 2#
4/ Check if you unlocked both badge, Hunter 2# might not unlock correctly in some cases (maybe linked to a disconnection ? I can’t remember clearly since i noticed it later)

Is there a way i can still get the awesome badge ?

Thanks for reading !


#2

Try fully exiting the app and reloading it then logging into the mastery screen and checking Bucket’s page to see if the badge has a little checkmark.


#3

Hi, thanks for the reply.
But i already tried that many times since a couple of days and it’s still not unlocked :confused:

I’ll try restarting my phone but i doubt it will change anything.


#4

If it still doesn’t work, the only thing I can think of is try completing one more battle with Bucket just in case, for some reason, he’s not ‘fully’ up to 30. I dunno why it’d be like that but you never know.

If that also doesn’t work, go to settings, feedback, and submit the bug :smile:


#5

Did some more battles too, didn’t work (i’m a QA Tester IRL i think i tried everything i could :p)

Didn’t think about the feedback thing, i’ll do it, thanks !


#6

Hello,

Did you ever find a solution to your problem? I’m currently facing the same issue with Lazarus and pretty bummed about it. I have all hunters to level 30 (got the achievement for it) and have played many additional battles with him. Restarted the app. My phone. Connected to the mastery page. It is the only thing on there that doesn’t say “achieved” next to it though I’ve clearly met the requirements.


#7

Hi, nope still discussing about it with the support ! I’ll keep you uptaded !


#8

I have the same issue with my Parnell badge. Has anyone tried unlinking from my2k and then logging back in?


#9

I actually have this issue on 3 hunters.
I also have a support ticket, running for 25 days now.

As a programmer the replies by support have been…
…depressing, to say the least.

Its actually seems to be a connection issue on leveling.
But basicly when the level up screen is not shown, the badge will not unlock.
And it never, ever, will…
Nothing you can do to fix it, 2k/catdaddy has to…


#10

That’s odd that you guys are having issues. I saw this post a while ago and brought it up with 2K an they mentioned more or less what you said Marnit. Since you already put an issue in to catdaddy all there is left to do is wait unfortunately. We don’t have any contact that I know of with them so it’s whenever they get to it I assume. Otherwise I would find out myself as to what is taking so long to reply.

I grinded out the level 30 icons for all the hunters after seeing this thread to see if some were just broken period but they all unlocked for me when I got them in-game. So not sure why some people aren’t seeing it work when you hit level 30. Hopefully catdaddy replies to you though considering how much time and effort I realize it takes to get to level 30 with even 1 character.


#11

A lot… it takes a lot of work… especially if you don’t pay to win… laz is so bad on higher levels… so so bad… :cry:


#12

It’s so true… I think the second area along with making him level 30 were the 2 most miserable points for me. I didn’t pay for anything so it was definitely sad times using him. I had around 30k mastery points when it came to making him level 30 so I just started pouring them into matches to heal so I could finish it.


#13

wow… you didn’t even expense a google play gift card to buy your way through? what a trooper…

shame you guys don’t have more (any really from the sound of it) control over the app though… your QA and balancing is leagues better than CD’s. :stuck_out_tongue:)


#14

Oh that sucks. I totally would have just expensed for some pay2win points… really you would think you’d have a debug version with shortcuts for levelling or heal cheats…


#15

Trust me, I asked initially for a tool to avoid the headaches but there wasn’t any that I could use. Figured everyone else would have unlocked it manually anyways and/ or paid to win so I just pushed through it manually in my free time. Least they are all done though :smiley:

Thanks Andrew! Took a long time to get it feeling as good as it does now. Even with the new hunters/ monster available, it will always be a work in progress to keep that balance consistent. I tried CoD a few times before and it didn’t seem balanced once you jumped into a game with people who know ADS tricks an all that jazz.


#16

Or are they?.. Check for updates. :smile:


#17

Your scaring me… :frowning: I will have to check after work since my phone is almost dead.


#18

mine died right after the update installed. xD (during accounting too which was horrible because that class is sooooo boring. haha)

(okay, don’t freak out though, but it makes you redo the tutorial after the update, i panicked thinking it reset at first, but once you get through it you’re fine. there’s actually some cool new stuff too. :smile:)


#19

Nooooooooooooooo!!!

Mine is completely broken… like Andrew said the update makes you redo the tutorial. But when it makes you build the reaver in the forest bestiary, it throws a network error, after which I’m trapped in the bestiary, and the app crashes when I swap to a different application. I can’t even submit a support ticket, because you’re supposed to do it in app but it skips the main menu until you do the effing tutorial!

I bet it’s because I finished the entire forest bestiary already. :cry:

I was 1 tyrant bone away from completing the desert biome too!

Sigh… time to kick around on the internet until I find someone to complain to…


#20

Why didn’t the update include the new hunters?