DEVICE_HUNG error ruined a comeback of a lifetime


#1

Holy crap do I wish I were recording and this just happened too. So I join a random game and it had given me the option to take over the Goliath bot. So I did. It was just as the game was beginning but the bot left a big trail of nothing but paw prints for the hunters to follow so I use this to my advantage. I lead the tracks further and go on a ‘detour’. After a while of sneaking and eating slowly.

The hunters caught me in a dome and I didn’t realize these were experienced players at the time. So I thought, "Alright, I got full armor and there’s a lot of space to move around, let’s try to get a few easy down penalities. So as I fought and leaped, I was able to damage them but not down any of them because they were a well coordinated team so I waited out the dome and leaped for my life while only having 2 1/2 bars of health left (remember I’m only stage 1). So I was running for the life of me but of course one of the players was an Abe so I had trouble getting out of line of sight especially with those stasis grenades and while I’m slowed, he’d dart me but once a leap would recharge, I’d book it. I got domed again but I was able to take out the Hank player and the Maggie player resulting in a down penalty each with about 4 bars of armor to spare (remember, still stage 1). I leap and leap and leap and climb over anything to complicate their precision. Finally after a clever outwitting, I lost the hunters for a brief moment while I made sure to get enough energy for stage 2 and so I evolved while I had the opportunity.

As soon as I was finished evolving, the hunters were right on my trail and closing in. I waited for the Assault to pass and right after he did I leaped for my life again, while taking a few rounds from the support which was funny enough that he was far from the group and right where I was heading. I knew not to engage so I climbed the cliff and kept running. I ran and ate every little creature I could get knowing I’d have enough time before they were right on me, but soon after I got full armor, they domed me again. I had to make sure to take down the Hank so he couldn’t cover Val so I made sure to get right on him. As soon as I got him down he called in an orbital on me but I knew better than to stay so I leaped away and leap smashed the already wounded trapper thus, giving me to opportunity to kill the last two. As the hunters were reviving the trapper, I focused on trying to get the last two hunters, so I got the assault after his final attempt to get me after I lost my armor but he was downed. I looked for the last hunter but they escaped. So I ran to go evolve.

So I find some striders and killed them then immediately evolved to stage 3. Since I had snacks left over I was able to get armor as quickly as possible after evolving in case they felt gutsy enough to dome me again in case they caught up again. But they didn’t. So I killed a couple more striders to get more armor, once I had more than 3/4 armor, I saw the timer for the reinforcements was about up so I decided to make my way to the power relay. But as soon as I was almost there, the screen froze and the pop-up appeared saying DXGI_DEVICE_HUNG_ERROR.

You have no idea how pissed I was. I almost punched something because this error happens all the time and I haven’t seen the devs recognize it in any manner and neither have the other players that commented in the thread about the same error. That is what ruins it for me. When I go against overwhelming odds and get punished for it because of a bad PC port. I mean you’ve seen the controls tab right? It’s an xbox controller display instead of a mouse and keyboard display. I really hope they fix this in the next patch. It would be greatly appreciated like they have no idea how happy they’d make me let alone the others having this issue. Thanks for reading this. Man I wished I filmed it because it would’ve had you on your toes and would’ve given you the same, “WTF” reaction I got. Peace.


DEVICE_HUNG Error
Current list of PC bugs (2/21/2015)
#2

That definitely sucks, I’ve had a few good games ruined because of the issue. I looked it up here and there are many threads about it, with at least one that has a dev response. I’m sure this is on the list of fixes, they are working super hard on the big ones right now (especially the progress reset). I’d encourage ya to just keep playing for the funzies of it and try to let these occurrences go as best you can (I know it is hard!). Hopefully a fix will be included with the upcoming patch.


#3

Happens to me all the time… So annoying…


#4

Man, that really sucks.I have had a lot of epic comebacks in this game, and I would be flustered to lose one to an error.


#5

You have no idea how frustrating this is sometimes…

Seriously, Monster leaves Support’s body, I go in as Laz, make it… And then he announces that his game crashed just as I run out of cloak, with Support having his ready.


#6

Needless to say, that game ended in a slaughterfest.

…For the Hunters. Amirite?

And am I using the slang correctly?


#7

Pretty much. The bot actually shielded me when I rezzed Assault, so it came down to a Stage three fight with two strikes and three HP bars.


#8

Oh I am man. I am. It’s just so frustrating when this happens. It’s ridiculous.


#9

Yes you are my man and it surely did. Goliath is my favorite monster and role to play as. When I’m him I become this primal assassin you wouldn’t even want to be in the same dome at stage 1. I know what it takes to take down a team of hunters. You just gotta play each card correctly no matter the situation at hand.


#10

I’m glad I’m not alone. Like seriously at least I’m not the only one.


#11

Dude this happens to me all the time every time I do an epic comeback. In that same game I said , “Please don’t crash on me game. I deserve this.” I was so mad my face could’ve been a comedy meme haha


#12

Still no fix for this. Lets go competetive with plenty of bugs! Yaaaaaaaaaaaaaaay! :smile: