DEVICE_HUNG Delay Trick


#1

Ok so I was having issues with Evolve crashing on me and giving me the DEVICE_HUNG error. If you have encountered this problem, I’ve got a temporary solution to delay the times it crashes exponentially. All you gotta do is uninstall your driver, then reinstall it with a clean installation under the custom installation tab (Nvidia). For AMD, etc users, I’d recommend trying the same thing. Also make sure under Manage 3D Settings, go to Program settings, select Evolve as your program and go to Multi-display/mixed-GPU acceleration and set it to Single Display Performance Mode. These steps will make it so it crashes a lot less often, thus making your Evolve experience a whole lot better. Hope I helped ya out and happy hunting! :smiley: