CryEngine Error Memory allocation

I reinstalled steam yesterday in an attempt to fix an issue with the steam client, which uninstalled my steam games. So I installed Evolve and started it up, as usual, but upon getting to the main menu the game crashes with the error.

“CryEngine Error” “*** Memory allocation for 4185240799 bytes failed ****, LevelHeapActive: no, Alignment:0”

However the game will not crash if I unplug my ethernet cable forcing the game into offline mode, allowing me to enter the options menu and little else. If I instead bog my internet down with downloads/streams, it still crashes but takes significantly longer to do so, allowing me to claim my login reward.

I have verified my cache on steam but it finds nothing wrong, if anyone has any idea as to what could be causing this, please do tell. The game used to run perfectly fine prior to the reinstall. I have 8GB of RAM a R7 370 graphics card and a fx-6350 CPU. EDIT: Forgot to mention, running on Windows 10.

Are your drivers up to date? AMD released a new update today.

Thank you for your response. I just tested out the new AMD drivers and unfortunately Evolve still crashes with the exact same error.

Can you try to verify the game cache integrity for me?

Alright, give me a few minutes. It takes quite a while on my HDD.

1 Like

Take your time, we have a few other steps to try as well, I will list them out for you.

Patch DirectX and VcRedistr from within the game’s folders

C:\Program Files(x86)\Steam\steamapps\common\EvolveGame\Game_CommonRedist\DirectX\DXSETUP.exe


C:\Program Files(x86)\Steam\steamapps\common\EvolveGame\Game_CommonRedist\Vcredistr (go in every folder and run every program)

You can also try

and this isn’t really targeted at your issue but…

Well the verification is actually downloading 3 files now, not sure why it didn’t pick them up when I did it yesterday. Tried your other suggestions in the meantime so keeping my fingers crossed.

EDIT: Darn, still no dice after that. Thought you might have been on to something for a bit, thanks for the suggestions so far though.

Alright, solved the problem. I went into %userprofile%/appdata/local and deleted the steam folder, everything needed reinstalling again, but it fixed Evolve and some steamwebhelper related problems I was having.

1 Like

Glad you got it sorted out!

And sorry for not replying sooner, I missed the notification.

I have been having the same problem lately, but it just happens in main menu if i hit play fast enough it wont happen. tried verifying game cache but problem still persist.
from the game log.
<14:44:33> =============================================================================
<14:44:33> *ERROR
<14:44:33> =============================================================================
<14:44:33> *** Memory allocation for 3266416845 bytes failed ****, LevelHeapActive: no, Alignment: 0
<14:44:33> Last System Error: Cannot create a file when that file already exists.

<14:44:33> Windows 7 64 bit SP 1 (build 6.1.7601)
<14:44:34> System language: English
<14:44:34> Windows Directory: “C:\windows”
<14:44:34> Local time is 14:44:34 08/01/16, system running for 2515 minutes
<14:44:34> 4001MB physical memory installed, 831MB available, 8388607MB virtual memory installed, 79 percent of memory in use
<14:44:34> PageFile usage: 1367MB, Working Set: 797MB, Peak PageFile usage: 1439MB,
<14:44:34> Current display mode is 1366x768x32, (Unknown graphics card)
<14:44:34> Japanese keyboard and 8+ button mouse installed
<14:44:34> --------------------------------------------------------------------------------
*** Memory allocation for 3266416845 bytes failed ****, LevelHeapActive: no, Alignment: 0

Have you tried any of these fixes?

Deleting the cache.m2k helped, but it have to be done every time before starting the game and it changed from crashing every time to crashing half of the time.
Thanks for the help.

Well, it’s a start at least. :confused: