Crash to desktop when starting multiplayer from main menu


#1

The game worked just a few months ago. Now, I can’t get past the main menu. Since then I’ve changed firewalls, but due to some debugging I am doing the firewall is completely open at the mo.

From the main menu, nothing seems out of the ordinary. I can wander in and out of menus and change options. But upon clicking multiplayer, the loading screen comes up for a couple of seconds and then insta-crash without any change, warning or error message.

  • GPU drivers updated today
  • Game cache verified
  • Firewall should allow the connections (but which ports can I add to make totally sure?)
  • Tried changing resolutions and switching from fullscreen to windowed fullscreen, as was suggested on reddit for a similar problem
  • Found 3 instances of micropatch.bak (in DLC folders 3 and onwards) and deleted them, as per this thread: Main Menu Multiplayer CTD (Crash to Desktop)

I wouldn’t think hardware is an issue, but here are the specs:
16GB RAM
Radeon HD 7800
Intel i7

Running W7 64bit


#2

@MajorLeeHyper @MrStrategio


#3

Do you have any programs running in the background? Well, I mean, anything more than the typical background stuff like browsers and what not.


#4

A couple, but none different than I’ve always had. It’s the usual background stuff, though - Spotify, Opera, Steam, Skype, and such.

Hamachi is dormant in the background (networks not powered on).

EDIT: Well, actually, I do use f.lux. But again, I’ve “always” used that.


#5

Try closing Flux and Hamachi and see if that helps… not sure it would, but anything is possible :stuck_out_tongue:


#6

By debugging, do you mean troubleshooting? Or are you actually using a debugging program?


#7

Closed f.lux and Hamachi, no change. Main menu --> Multiplayer --> Loading screen (“Waiting for servers”) --> 4-5 seconds later, CTD.

And no, I am not programmatically debugging anything. I’m actually not troubleshooting either. I just haven’t set up all the firewall rules, and it’s a bit time-consuming, so for now I’ve done my best to allow all connections until the individual rules are in place.


#8

Okay, well time to go extreme here… Uninstall the game and ensure that all of its files are removed from the steam directory. And then re-install it… This will probably take you a few hours depending on your bandwith.

If this does not resolve the issue, I’ll need you to submit a ticket to 2K support. If you’re in the US here is a link to the page: http://support.2k.com/hc/en-us/requests/new?ticket_form_id=46466

In the event that this does not solve your issue, please send me the ticket number in a PM after you submit it, so I can follow up with 2k about it.


#9

Playing in solo mode works fine, btw:
http://imgur.com/dHfH6KR

I’m in Europe. Is there a different place I need to submit tickets for my region?


#10

Bro, why’d you dome?


#11

I’m not sure, try following the link to see if it works :slight_smile:


#12

Alright, reinstall under way.

While I am waiting, do you know where I can find which ports need to be forwarded for Evolve?

Also, your forum is damn slick. Is it custom or can interested parties acquire it somehow?


#13

#1262805 @ 2k


#14

Small update: the issue isn’t resolved yet, but enabling uPnP seems to be a step forward. It takes 10 tries to get into multiplayer now, and so far I haven’t been able to connect to a game… but it must be an improvement still.


#15

thread necrophilia intensifies

Still borked. System is updated, firewall is updated, ports are forwarded, NAT is tweaked, Evolve still crashing. :confused:


#16

That is one helluva rez!

Are you playing Stage 2?


#17

That screenshot is from before stage 2. Tried to get in today, but my problem persists despite hours of intense network tweaking and complete game reinstall. So at the moment, no, I am not playing stage 2 :stuck_out_tongue:


#18

You know what I mean! :laughing:

This is entirely network related?


#19

As far as I can tell. It worked fine without a single problem over several 10s of games before I switched routers. On the new router, I haven’t been able to join a single game (despite probably 150 attempts). Switching back is sadly not an option.

So I can only assume it has to do with networking, or even more specifically, NAT handling. 2k weren’t able to fix it either the last time I talked to them.


#20

Is the router assigned by your isp or can you test a different one?