Cant start evolve stage 2 plz help

when I start evolve on steam it says running and then synchronizing then immediately afterword evolve never opens and after ive uninstalled and reinstalled multiple times it wont fix its self, or even after I verify game cache


He will help ya help!

Welcome to the Forums!

1 Like

hi, what do I need to do?

So, unfortunately I personally do not have an answer, but I tagged a Developer, Brandon Yanez who can help you.

ok, thank you

No problem, glad to help

Evolve Stage 2 Crashes on Startup

If Evolve.exe actually runs when you press Play, (you can verify it’s
running with either Task Manager or SysInternals Process Explorer), but
then crashes, and Verify Integrity hasn’t fixed it, there could be
several ways to go.


If it fails within 3 seconds or so, and no Game.log or error.dmp is emitted, then:

  1. Make sure your antivirus/background app is not quarantining the game (see this Steam article1 for help on how to disable background apps)
  2. Make sure Steam is running and you are in Online mode.


Evolve needs access to the Internet, even in solo modes. Please make sure your firewall allows Evolve.exe through.

User Data

If you had an older version of Evolve, then got the new hotness version and now
it crashes, or it launches but the window is all messed up, or you have
a black screen or bizarre rendering glitches, you may want to try
deleting Evolve’s user data using this batch file2 (Google Drive download.)

Instructions for use:

  1. Put it anywhere.
  2. Double-click the file.
  3. Runs quickly and disappears = Good.
  4. Red text, box stays open for you to read it = Bad.

here you go, hopefully this helps

ok, I look through my firewall and evolve seams to be going through. and I just got the game on pc. and I didn’t quite understand where you said see the steam articale1

For some odd reason, there is a huge indentation lol ^^

Just ignore it

Edit: Well none of the articles work for some reason.

ummm, when I click on any of these links its says "Help Desk Error

The specified article does not exist or you do not have permission to view it."

You know the link in my first post? Click on it and you will a section for steam articles in the main post

ok, I have done what is said to do, do I now try to start evolve?

All i did was exit steam and open it again.

1 Like

yep, did it work?

Is this in any way connected to my problem where I can’t even play the game for more than 24 hours now? (Can’t log in due to “Evolve profile service” error.)

No, it didn’t work. I downloaded it On my laptop and it works fine

YEAH!!! It worked! Thanks!