Can't load any game on XboxOne D:


#1

I’m trying to play online but I get stuck in loading for more than five minutes and my internet is working fine, please help, I want to try the new patch( today will be my first day playing with the new patch) but I can’t
@MacMan
@MrStrategio
@Shaners


#2

Have you tried shutting the XBone completely off for a couple minutes and then turn it back on?


#3

I’ll try that


#4

Xbox live is having issues right now, the same thing is happening to me and my friends.


#5

Yeah, I’m hearing Xbox live troubles.


#6

That works to :stuck_out_tongue:


#7

Ok then, at least I got that clear, thank you guys for informing me


#8

Happening to me too. I finally got a game after like ten minutes of waiting and constantly restarting my XBOX


#9

So, I’m still not able to get in a game on xbox. Is xbox live down across the board or just for evolve?

It looks like I’m online just fine. I simply can’t find a game.


#10

Yeah, Xbox Live was so bad earlier… :S


#11

I can’t get in either…


#12

I just joined a game, I think it’s already fixed