Can't join sessions bc of "wrong disc" error


#1

First off, if this is the wrong location for this post I apologize :confused: please correct it.

So here’s the issue. I started out with the standard edition of Evolve. Then gamestop had a sale of the Ultimate Edition. So I traded in my original copy and bought the new one. NBD right? Well, what was interesting is the PS4 had to reinstall EVERYTHING about the game. Now, when I try to join sessions with someone who I guess owns the standard edition, it tells me I have the “wrong disc inserted”…

Am I missing something? I mean, it’s the same game. The new disc just came with a pass for all the DLC, right? So what do I do? I didn’t think it made sense to have two copies of one game.


#2

This is a new one. @Insane_521 any thoughts on this?


#3

Try resetting your system, if that doesn’t work try uninstalling and reinstalling the game


#4

Not a bad idea, reinstalling the game that is. I shouldn’t be losing any progress either, right?


#5

Oh, I thought you already tried reinstalling.

Yes, try a full uninstall. Then unplug the power and ethernet cable, for a minute or two, then plug back in and reinstall.

Keep us updated!

Edit: Your progress is tied to your My2k account. You shouldn’t lose anything.


#6

I have the Ultimate Edition, and when I went online, I got into games just fine. I’m assuming they had the regular edition. I’m on PS4 as well. It must be something with your PS4. Hope it gets fixed!


#7

Alright I’ve uninstalled it. I’ll let you guys know what happens when it’s back up.


#8

What’s the latest version supposed to be? Before uninstalling I checked for updates on the Ultimate Edition and it said 1.03 was the newest. But for the original Evolve it said 1.09 was the newest. Both updated on 1/27/16 and 1/28/16


#9

@TheMountainThatRoars after reinstalling I am no longer getting a play station notification saying “wrong disc”. I just get a message IN-GAME saying I can’t connect. BUT! I believe that’s due to the typical weekend server issue on ps4. So… i guess it’s resolved? Still haven’t successfully joined a party yet. But at least it’s not the same issue! I’ll try again when servers are g2g.


#10

All is fixed! I’m good to go! Thanks for the suggestions :slight_smile:


#11

Awesome, glad you’re back in the game!


#12

I am not having the exact same issue, although I felt it was appropriate to atleast bring this up here… I am on ps4 as well and all day since roughly 10:00 am “through when the time on this response is” and still currently having problems “connecting” , I have tried restarting the app/game as well as reset my router, tried other online games (that worked fine btw) and performed an Internet connection test to boot and still to no avail…I’m guess it is the Evolve servers


#13

Your problem sounds like this one.

The devs are looking into it. There are more details including an update from LadieAuPair in the thread I linked.