Can't get Behemoth?!


#1

I put in the monster expansion pack code when the game came out and it says I still have to pay $15 for it! Can someone help me


#2

What platform are you on?


#3

Somebody helped me with this yesterday, if you’re on xbox one, go to ‘games and apps’ go to evolve and click the menu button, go to ‘manage game’ and go over to the right where it’ll show items ready for download.


#4

Try this:

Also the search function in the top right is your best friend. :smile:


#5

Beat me to it. :laughing:


#6

Yes this exactly OP. I had the same problem but this worked just fine on the Xbone. You will have to scroll right past all the other little download packets you have (if you have any, ie skins and such) and then you will see an “Items Waiting to be Downloaded” or something to that nature.


#7

Hahaha! You explained it better, though. Thanks again man. Question, how do I quote posts? I’m on mobile.


#8

No idea, sorry. I tried using my mobile last night and couldn’t figure it out. :smile:


#9

Probably can’t on mobile, then. All good!


#10

Just use a “>” before the quoted text. :smile:

example


#11

I get “body is invalid; try to be a little more descriptive” when I try it.


#12

Hmmmm, not sure then. Sorry.

You can also try 5 spaces before the text.

 example

#13

What about quoting someone else’s post? Sorry that this is super OT


#14

It’s not easy to do via mobile. When I need to, I switch to desktop view for a few seconds then switch back after posting.


#15

THANK YOU ALL!! It worked now I can do my video on behemoth! Thx so much u guys​:smile::+1:


#16

No problem. :smile:


#17

Since your question was answered I am going to go ahead and close this. :smile:


#18