Cannot play Evolve online (My2K login disabled)


#1

I would also like to understand when this will be addressed? My son has been forced to play offline because of this issue since launch. I control what he plays and based on the fact that offline and online gameplay are identical there is no reason to not let him play with this friends. It curses like crazy in solo mode, what are you protecting him from by staying offline?

To make matters worse he just purchased the Gorgon DLC and even though he has the email bill, and the Xbox store confirms the purchase, the game refuses to let him play as the monster. It tells him it’s locked. Any matter of uninstall and reinstall does not resolve the issue.


Evolve Login
#2

Have you tried the fixes noted above (adjusting the age in the linked My2k account)?


#3

There is no linked account. The option is disabled in the game UI.


#4

Is his account part of the Xbox family share account?


#5

Not sure I understand. His account is his own but it might be assigned as a family member under mine. He can play every other online game just fine. It’s just Evolve that he has these problems with and I don’t even get an option to say I approve of my son playing this game (or use the content he paid money for). It says age means no online, period.


#6

Please try these two options, let me know if either of them work.

http://support.xbox.com/en-US/xbox-one/security/promote-child-account


#7

I have tried both of these options. My son’s account actually shows him as 19 (which he isn’t but lately some games have forced me to do this so that I have control of his gaming habits and not the games themselves) in his MS account. It seems the game is validating against something different than what Live is reporting and making it’s own more restrictive determination that I just cannot override.


#8

Well, I just did some searching and I am sure I found all the same posts you did.

I am going to move your post into a brand new topic. Hopefully someone from TRS can help point you in the right direction. If you haven’t already done so, please fill out a 2K support ticket. http://support.2k.com/hc/en-us/requests/new


#9

I opened a ticket 3 days ago and have heard no response. My son still cannot play the content he paid for. Pretty sure the studio should be a little concerned about that.


#10

Hello!

This is a weird one and I haven’t heard of something like this before. I can start poking around on this side, but it might take a bit since I’m not totally sure where to start.

As for the support ticket with 2K, it’s not always the fasted turn around and it’s fairly standard for them to take 3-5 business days to respond.

However, if they respond before I come up with a solution, can you forward your emails with them? You can just send it community@turtlerockstudios.com and put ATTN: Tara in the subject.

Thanks!


#11

Still haven’t heard anything from the ticket, but if I do I will forward the communications. Also let me know if there is any information you need to help investigate the issue further. Thanks.


#12

Alright, I’m still not sure what’s causing this, but we should first make sure there isn’t something weird that is being stored on the Xbox’s local memory. There is a slight chance this could fix the issue, but I doubt it. It’s just better to do this as a precautionary first step.

Turn off the XBox One, completely - not just putting it in rest mode. After it’s powered off, disconnect the power cable and the ethernet cable. Let the system sit powerless for at least 5 minutes. Then hook it back up.

Check and see if there is any different then.

I’m also wondering if it works correctly on other XBoxes for you son. If he downloads his profile onto a friend’s XBox and tries to play, does he still encounter this issue?