Cannot Launch Evolve PC


#1

I have Evolve on PC Steam, I have reinstalled the game twice and verified the games Cache a dozen times as well as restarting my pc and steam but nothing works. All that happens is the box shows up that says “Preparing to launch Evolve” then it goes away after 1-2 seconds and nothing happens, no launcher no 2K sign in not even a error message, Can anyone help/ Has anyone had this issue and fixed it?. please help i payed 80 dollars for this.


#2

I am having the same issue Crashes immediately on attempt to launch. I have gone through Steam TSing. Uninstalled and reinstalled rebooted, verified install data, everything I can think of and still can’t launch Evolve. No other steam game has the problem and the error message I get is very generic. Just says Evolve failed to load and windows searches for a problem. I have better than min and in most cases better than recommended specs. a10-6700 CPU @ 3.8GHZ, 16G of RAM, and Radeon HD8670D.


#3

I have the exact same problem, except before the game stops, it gets as far as making the screen black for a split second and putting my mouse in the center of the screen. Tried using the different launch options suggested and still no luck. No error message, it just says I’m not in game anymore. Played in the Big Alpha and XBOne Beta and never had this problem. Help would be appreciated.


#4

My brother is having the same issue. Validating the files worked for him.

Right click game in library --> properties --> local files --> verify integrity of game cache.

It seems that fixes it for some people and not for others (my brother had 179 files to validate apparently). Good luck guys. It seems a fairly widespread issue so if you can’t get it resolved on your own, Turtle Rock is probably aware of it and hopefully working on a fix.


#5

so far, I have validated twice, reinstalled the game, and tried several launch options as well as going into the Evolve folder and manually starting Evolve. All of them have had the exact same result.

Edit: Not sure if this is useful, but when I set the privilege level of Evolve.exe to administrator, Evolve would have the same problem except once the game stopped, it would start right back up again and go in an infinite loop of launching and closing the game. Hope this helps.


#6

Fixed!
Finally got it working. I needed to update my NVIDIA driver.
This link is what did it for me. http://www.wikihow.com/Find-and-Update-Drivers
Hope this helps someone!