Cannot buy any characters nor access the store

Type (ie. Gameplay, UI):
Map/Map Location:
Game Mode:
Platform: Windows

Can you tell us the steps to reproduce the issue or what you were doing when the issue occurred?

  1. I am not able to access the store. It says “Store is currently unavailable”. I am attaching the corresponding images. Please help. I verified the cache, updated the game.

Any additional information (pictures, videos, errors codes, etc) to help reproduce or locate the problem?

I am also not able to purchase any characters. Attaching the corresponding images as well.

Are you still seeing this?

It’s possibly due to a connection issue with My2K.

Try the step that involves deleting the my2k cache and Verify your game files, then see if the issue still happens afterwards upon restart:

Yes it has been the same for the past week, probably after the 2.13 update because I did buy some perks earlier. I tried linking my steam account with 2K to see if that helped, tried it after unlinking from 2K. The issue continues. The store never opens. I read some where to delete the cache.m2k and precache.m2k and restart the game. Tried that, did not work.

I appreciate the quick responses. I created a new steam account to see if it allowed me to buy characters, but the issue persisted. I read about the my2k cache issue. I will delete the client.m2k file and see if it works.

To report further, none of the steps worked.
I deleted client.m2k, cache.m2k and precache.m2k but still the store is unavailable. All characters are locked out.

Please any help is appreciated. I enjoy the game with the characters that are pre-unlocked but playing only with Goliath and 1 in each class sucks.

If its not affected, you might wanna stick to solo for the time being for the sake of variety since all characters and perks are unlocked in solo.

I got this error also. :frowning:

Well playing with AI is not that much fun. But guess I have no options.

Let me know if and when you manage to workaround this. Thanks.

Try perhaps this:

You should put in a customer support ticket with 2K regarding your issue that way it gets pushed from both sides.

  • Gertz

The issue seems to be with the internet connection, I managed to access the store using internet from a different service provider.

1 Like

The Store works again, and I was able to buy Perks again… I didn’t have to do anything. :slight_smile:

I deleted client.m2k, cache.m2k and precache.m2k + verifying of the game cache but still the store and crates is unavailable, I can’t buy perks etc. Google DNS don’t help me.

I’ve been having this problem for a couple weeks, can’t access the store or open crates. I’ve tried reinstalling, verifying cache and changing the DNS with no luck. Has anyone been able to fix this problem?

OK so a little bit of observation made by me. Hope it helps. If you have an internet connection which implements the Fair Usage Policy, whereby service provider throttles your net speed after usage of a certain number of GB, you may not be able to access the store, once the speed is throttled. It is just an observation based on my system, may not apply universally.

I have the same problem here. To add on to the store problem, my evolve client sometimes has the “profile service error” where I can neither get the daily rewards, open any crates or play any online multiplayer matches.

I have tried deleting both the precache and cache files and verified files, but that method didn’t help at all. I had tried reinstalling which then helped to let me play the game for awhile, and when I do come back to evolve, the profile service error is back. The game seemed to only work a few times after I restarted steam and re-entered the game, but the store and crates are still unavailable.

FYI also… this is also affecting the store in legacy evolve on Xbox… I recently tried to buy a skin and received the error msg