Cannot access the Store!

pc

#1

Its been 2 days or so that I’ve been plagued with this “Could not connect to my2K. Please check your internet connection”.
I’ve done alot of things that I saw on the internet that seemed to fix the problem such as:
-Changing my name to something without special characetrs
-Opening steam as admin.
-Checking the integrity of the game cache
-Trying to link my account to 2k (which I cant because I still get an error about connecting to my2K.)
-Removing all my antivirus’ modules and windows firewall.

Im honestly out of ideas and I desire to play this game :(.
Please help!


#2

@Gertz any ideas?


#3

Anything? D:


#4

Have you tried restarting your modem and router?
I think someone here had some success with that, can’t remember. But it can’t hurt to try!


#5

Actually tried to reset my router, but it did not work.
Something that worked though:
-Created a new Steam account
-Tried to log in, totally new everything, stats, silver keys and etc.
-It managed to connect to the my2K.

So whats the deal then? I still cant connect on my main account but on the just recently created account I can?
The weird thing is, I cant even link my account to the my2K on my main cuz the game just kicks me out of it.
I didnt even have to link my fake account to 2k and it worked.
Any ideas guys?


#6

Do you happen to have any other 2K games you’ve bought that use the my2K account? If so you should see if you’re getting the same problem with them or if it’s just Evolve.

Or you could submit a 2K support ticket and see what they say:
http://support.2k.com/hc/en-us/requests/new


#7

Thing is, it was working before. I played it already and it worked fine, even bought characters and stuff.
All of a sudden it didnt work anymore. Wasnt even on patch day or anything, just didnt work anymore.
I’ve heard the 2k support is horrible, maybe i’ll try later.

EDIT: I dont own any 2K game apart from Evolve Stage 2.


#8

Can you play at all on your main account? Is it just the Store that doesnt load?

Can you post the URL to your Steam Profile, Id like to look up your account on our end to see if anything sees out of place.

I would also try this on your main account:

  • Navigate to your local game files by right clicking on Evolve Stage 2 in your games library
  • Select Properties from the drop down list
  • On the new window select Local Files
  • Choose Browse Local Files
  • Find the “precache.m2k” and “cache.m2k” files and delete them
  • Restart the game
  • Gertz

#9

http://steamcommunity.com/profiles/76561198018936664/ is my Steam Profile.
I can indeed play the game sometimes, sometimes I cant. Its kinda weird because some times both play and store and greyed out, and sometimes they arent but the Store says that I cant get a connection going.
I will try what you said, thanks for the help!

UPDATE: IT WORKED!! I cant thank you enough my man. Thank you so much I can finally play this again :smiley:


#10

Glad to hear

Did deleting the cache files work?

  • Gertz

#11

Yes it did!


#12

Thanks.

Going to try and force a cache update so we can weed out any cache related issues we are having

  • Gertz