Attention: Server Connection Failed


#1

I’m sure TRS is aware of this issue but I’m posting this anyways because I’m not sure exactly how isolated this particular problem is. Every time I try to connect to MP I get the following error message below.

"Attention: Server Connection Failed. Please check your network connection and configuration and try again."

I have double check everything on my end. Router, Firewall, Virtual Server, and I have even gone to the extent to re-install the game thinking that maybe there was an issue with a .cfg file somewhere. Still no luck, I’m sure this is an issue on TRS side just letting you guys know in case you didn’t ;-P.

Thank you


#2

Also having this issue.


#3

I’m having this issue this morning. My internet is fine (I’m posting this), so I’m not sure why the servers are down.


#4

same issue here mate im yet to play multiplayer still haven’t heard anything from 2k


#5

Have the same issue. I’ve searched high and low for answers, seems like I’m not the only one. Have not been able to play online since I got the game, really disappointed…


#6

March 15th and i STILL haven’t played a single game of multiplayer on evolve… I’m really depressed about this actually. I spent 60 dollars on the game for crying out loud. I contacted 2k support and they claimed the problem was on TRS end. Patch 1.1 came and its still not fixed. i’ve lost all hope.


#7

please read, i think this information would be of value to you

atleast i didn’t spend 60 dollars but instead 8, it still dissapoints me that i have to play singleplayer all the time, especially when people are asking me to play with them couse i know how fun it would be. though i have some good information on it, couse like you said. it didd’t have anything to do with internet when the message pops up, becouse when i start the game (same account same password and same way) on another pc it works. so therefor it either seems like the individual pc cant connect or, i have no idea.


#8

due to the age of the thread, you’re better off making your own topic.


#9

I have to agree.
@tarkua_unofoxiall, I will close this thread as it’s a year old and more, please feel free to make a new bug report on this and provide as much info as possible as to what’s going on.

Good luck :slight_smile:


#10