Anyone could help me with random frame drops on PC? [SOLVED]

pc
#1

So i have been having some random frame drops with my new PC.

My build is:
intel Core i7 8700K
Geforce RTX 2070 Gigabyte 8GB VRAM
16GB RAM 3000mhz
Asus Rog Strix Z-370H
700W PSU
1TB SSD Crucial MX500 (C:)
1TB HDD Seagate Barracuda (D:)

So what happens exactly is that after 30 minutes almost, no matter what game i play, i get random FPS drops from (for example) 120 to 20 like a little screen freeze.
I checked all drivers. Everything seems fine.
I checked the GPU temperature while playing. Everything was ok.
I checked the CPU temperature while playing. Everything was ok.
Looked around on google and some were having similar issues but not as mine/ had the same as mine but resolved with drivers.
What should i do?

Edit: found out it makes that little freeze even out of gaming situations. The thing that might seem important is that ONLY video stutters. Audio is extremely fine while the stutter happens.

#2

Have you tried picking the frames back up after you drop them?

1 Like
#3

I’m completely spitballing here, is your cpu or system set to power saving mode?

https://support.steampowered.com/kb_article.php?ref=2715-YIPD-6873

2 Likes
#4

No, i also disabled overclock just to be sure. But i am quite sure it isn’t set to power saving mode.

#5

Did you check the other items listed in that article?

#6

As soon as i get home i’ll try keep track of cpu temperature through asus ai suite 3. Although, when these freezes happen, everything is fine temperature wise: 35 C for GPU and 43 C for CPU.
For SSD it’s ok, i have a specific program made by Crucial for maintenance of my SSD and did all the needed operations.
For RAM i have 16GB. Already tried to use a program that also clears the standby memory list when it exceeds a certain amount of memory usage but with no success in solving these random freezes.
Edit: about game settings etc. Freezes happen even with League of Legends. The same way as they happen with Monster Hunter World or any other game. Same frequence. Same frame drop quantity.

#7

So i managed to track the frame rate drops. Whenever the hiccups happen, the GPU Usage goes down, this might seem pretty obvious/stupid though. However i found out one weird thing: it only happens after a certain hour of the day, like 8 PM.

#8

Might check with the power company about fluctuations?

#9

Step One… Load NOTHING at start up.
Step Two… Load offending game.
Step Three… ??
Step Four… Profit.

edit :: ON a similar note… I have been fighting a lot issues with slow down halts of my system… I went into the windows settings and reset network and rebooted… currently its working… but the halts would come down almost like clockwork and it would just stop everything… maybe MS did some tweaking under the hood… If it continues to happen I will let ya know.

2 Likes
#10

step one… disable windows update sharing…
step two… install game to 2ndary drive… not the Windows one…
step three… disable windows 10 game mode. if your using it. Its in the settings under gaming.
step 4… If you have a power-supply that isn’t up to the task of ruining your hardware… upgrade… I had random crashes and reboots when i first tried evolve… due to my pos power-supply. 600 watts on a pc and gpu that draw less than 400 watts I should have been fine.
Thats all i got…

3 Likes
#11

Are you sure 700W aren’t enough for the rig? I mean, the PSU i bought isn’t a crappy one like a bought for my old computer, i spent at least 100€ for that. Also, if the PSU wasn’t enough, it should give problems right from the beginning, not after 6/7 hours, shouldn’t it? Also, i’m not getting any crashes or reboots like you did, just little screen freezes.
About games on HDD and not on SSD: yeah, maybe i should try to transfer stuff on the HDD.

#12

700W should be more than enough.

2 Likes
#13

Did all you said, lets see if tonight goes alright. Thanks in advance

#14

You know what… My secondary hard drive, even though I will be playing a game or something off my SSD, recently like within the last week, they system has been spinning down the disk and when that happens, my internet hangs and so does other programs not associated with the hdd.

I am about to disable the drive and run purely off my ssd. its only a 250gb one though… so I have to be picky.

Edit::HDD disconnected, system already a lot happier… will inform if this resolves my similar issues later on in the day.

Overwatch, Spellbound, Destiny and one more game can fit on the drive.

1 Like
#15

Nothing changed, but i discovered that rebooting my pc fixes the problem (it still goes back to random hiccups after a few hours as usual). I’ll try to disable HDD as @Kathryn_James suggested

1 Like
#16

I can say that after all these hours my computer is feeling a heck of a lot more stableized. I think MS had an update not too long ago and shortly after that I started having issues.

Now I am still using my computer without the need to reboot it. (knocks on wood)

2 Likes
#17

Naturally HDDs are a lot slower than SSDs so perhaps there could be an issue there but I’m honestly not sure what would make it jitter, unless the HDD is a low speed one which means it could struggle to keep up and process things.

2 Likes
#18

It’s a 7200Rpm if i ain’t wrong. The weird thing is that it is almost empty. I just keep all my unity projects while on ssd i have everything.
Edit: even more weird, these hiccups started this month and i built the pc back in november

2 Likes
#19

Same here 7200 rpm on the hdd, but what i was noticing was what I explained earlier. For no reason windows 10 must of been doing something with it to beyond what they used to… idk if they changed drivers, protocols or managment in some way… But still running strong and my internet has been good too.

But maybe it has something to do with indexing by windows and all of that… I dunno. Happy to be running on just my ssd now, but i sure do miss that TB of space.

(ps, my drive wasnt even half full)

1 Like
#20

I’ve also noticed that my 4 terabyte game drive tends to be pined to 100 percent when I’m not using my pc… I do think its something windows 10 is doing. but its never effected gaming for me. I am 100% Amd, Ryzen and rx 480… so not sure if that matters. That is why I always keep task manager running to the left of the rest of my screens to see whats going on. Like Kathryn said… Maybe turn of Indexing on the drive? Or if anything Unity related is running close it? I don’t know but its worth a try. :slight_smile:
on another note my alienware laptop with intell and sli gtx 880s seems to do the same thing. Its probably an indexing thing. Hope this helps…

2 Likes