A connection to my2k could not be established. Online profile and my2K features will not be accessible. [XBOX ONE]


#1

Hi there,

i do encounter this issue now for more than three days in a row. I have done numerous tips from the forum, even from the my2K support. Nothing helped. I have erased the whole game re-installed it but just the game no addons, still not working. I can only play the offline mode but as soon as i go out of the current game, instead of bringing me to the home screen it does bring me back to the Intro. Does anyone have the same issue as me?


#2

Are you able to access your purchased dlc (assuming you bought any characters or skins)?

Also, are you able to access the store at all?


#3

Hi,

yes, i bought characters and skin packs. (hunting season 1 & 2). No, I cannot go to the store, it is unavailable. I can play other games online just fine.

Any suggestions?


#4

So you can use your t4 and t5 characters and your skins but can’t access the store or play online? (I ask just to confirm everything you can and can’t do)

This is so weird. Someone else had the problem of not being able to play online, but a full reinstall worked for them.

You could try a hard reset (hold down the power button until the xbox turns off), but I doubt it would do much as it sounds like an issue connecting to the games servers.

I’ll tag @LadieAuPair and @MajorLeeHyper to see if they are able to help.


#5

Could try try un-linking your my2k ID for me and let me know if that resolves the issue?


#6

Hi Jedi,

No, i cannot access the t4 or t5 skins or characters. I have access only to the normal characters with their custom skins.

I have even reset my console once and it didnt work. It is super weird. This all happened after the installation of the new xbox one update to me.


#7

Hi LadieAuPair,

I have done this as well but now I cannot even link it anymore. It brings me always to the damn cinematic screen, when I try to do it.


#8

Could you try deleting your save data off the console and relaunching? (don’t uninstall the game, just delete the save data)


#9

If this won’t work, should i try with deleting everything, like even from the cloud storage?


#10

Don’t delete the game, but yes, you should also probably delete your cloud storage.

You won’t lose your level or progression by doing this, this is saved on our end for safe keeping.


#11

Okay, I just deleted everything and have still the same issue. I have no idea what else to do. @2k could you please check my account on your side?


#12

Hmm, deleting all the save data should have meant it couldn’t have signed in because it didn’t know your account, and it should have prompted you to connect a my2k account like it did the first time it launched.

What exactly is happening now?

(Also, adding @MajorLeeHyper in case he has other thoughts)


#13

Alright, I am sick of typing my issue. I made a video now.

Click on the Link.

Maybe this will help?


#14

In the main screen the version of the game isn’t correct, i suppose.

Check the picture.

Thanks!


#15

So now no-one is replying anymore, since you can see how i struggle now for 5 days in a row??


#16

Just wait. The Devs don’t have all the time in the world and they sure can’t be on the Forums %100 of the time.


#17

Well, I am already waiting for 5 days. I for some reason have the feeling it must be something wrong with my account. As you can see in the video, it keeps asking me who i am. This is more than strange.
In other games, there is no such a behaviour. Just saying. I really wanna play this game again and its so frustrating.


#18

That’s understandable, but all of this takes time. So just be patient, even more than you already have.


#19

Hi there,

are there any new informations? I just checked the game on playstation 4 and thereit works just fine.


#20

Do you have the Ultimate Edition on PS4?