A connection to my2K cannot be established


#1

Hello,

I have trouble connecting to my2k servers on PC via Steam. This is what happens:

I turn the game on, get to the cinematic, the text “signing in as znaleziatko” appears in the bottom right corner, and then the information pops up “Status - A connection to my2K cannot be established. Online profile and my2k features will not be accessible.”. After that I get the game menu but actually can’t do much without the connection. I can’t link the game with my my2k account because there’s no connection.

I played beta some time ago. When I first launched the game yesterday I had the “I agree to all” policy requirement part but the game didn’t ask to link with my2k account. Then I got through both tutorials and after that I came to the point where I’m stuck now.

Yesterday I bought two copies of the game: one for me and one for my husband. We are playing from the same LAN network (same room). He can play the game in multiplayer mode without any issues while I can not. I don’t have any anti virus software active and my firewall is disabled. I can play other Steam mutliplayer games without any issues as well.

I have tried reinstalling the game and restarting Steam/PC without any success.

What can be done to fix this issue? I would appreciate any help.


#2

having the same problem here, did you verify your my2k account already ?


#3

Yes, I have verified my2k account.


#4

hm. I was thinking that would be the case, seem it isnt, i am in contact with 2k support and will let you know if should i find out anything


#5

Thanks, appreciate that. I have submited a ticket myself as well, awaiting answer.


#6

Fixed! Reinstalling steam and downloading game again worked.


#7

i will try reinstalling steam. lets hope it works


#8

2K’s servers have been having some issues lately. It may help them find what is wrong faster if you copy this report to their forums.


#9

im already in contact with 2k support with an extensive report of whats going on, but thanks


#10

You rock! Thank you :smile:


#11

well, reinstallling steam and reinstalling evolve did not fix the issue


#12

I have exactly the same issue as OP. Please post updates.


#13

Yeah, I have updated my ticket to 2k support as well notifying them that I fixed the issue by reinstalling Steam.


#14

well. bad news. after reinstalling steam and evolve and re-doing the tutorial i got reset :frowning:
still no answer from 2k support


#15

ok wow UPDATE :
changing my STEAM name from one beginning with a signma ( Σ(OAO") ) to my main handle fixed the issue …

if that aint wierd I dont know what is


#16

Holy shitballs. It was the same for me. I had " and nordic characters in my name. changed to all english and now it works perfectly…

Bad coding mayhaps?


#17

I’ve had the game for about a week now and have been having the same issue. No response from 2ksupport as of yet. Is there a known fix for this?


#18

aight, from what weve found theres a few things that can cause this :

  • special characters in your name, try changing your steam name to something without them, this fixed it for me. Maybe even something that resemblems/is the same as your my2k account name
  • reinstalling steam/the game ( THIS WILL RESET YOUR PROGRESS FOR SOME REASON ! )
  • verifying your my2k account via email

#19

My steam and 2k account name are the same as here. I have verified my account via e-mail and I did try re-installing the game which didn’t work, but I did not try reinstalling steam. I’ll try that and will update whether or not it resolved the issue.


#20

just be wary, as it might reset your progress
does your steam name contain ANY special signs, punctuation marks or anything that is not regular text ?